veket官方网站论坛

veket

 找回密码
 要注册
搜索
查看: 449|回复: 2

chromium的浏览器和Microsoft Edge无法切换输入法

[复制链接]
发表于 2023-7-8 23:11 | 显示全部楼层 |阅读模式
chromium的浏览器和Microsoft Edge无法切换输入法
找到原因如下
Chromium或者任何基于chromium的浏览器(例如,Microsoft Edge)

对于在 X11 下运行的 Chromium,如果使用没有设置 DBUS_SESSION_BUS_ADDRESS 选项的 startx 启动图形用户界面,可能会遇到 这个问题,它会导致基于 Chromium 的浏览器无法正确使用 dbus。为了解决这种情况,可以这么做:

1. 在 ~/.xinitrc 中自己导出 DBUS_SESSION_BUS_ADDRESS(或者如果您使用的是基于 debian 的系统,则更改为使用 ~/.xsession)。

2. 或者使用像sddm、gdm、lightdm这样的显示管理器替代startx。

对于在 wayland 下原生运行的 Chromium,唯一支持的原生 wayland 输入法协议是text-input-v1,只有 weston 支持。或者,也可以使用 Gtk4 的 im 模块,需要使用以下标志 (---enable-features=UseOzonePlatform --ozone-platform=wayland --gtk-version=4) 来使其启用 Gtk im 模块,但是除非使用 kimpanel + GNOME,否则在光标位置弹出候选词窗口的功能就完全坏掉了。

https://fcitx-im.org/wiki/FAQ/zh-hans
请教一下大佬
第一条
在 ~/.xinitrc 中自己导出 DBUS_SESSION_BUS_ADDRESS(或者如果您使用的是基于 debian 的系统,则更改为使用 ~/.xsession)

应该怎么操作????
发表于 2023-7-9 07:42 | 显示全部楼层
/root/.xinitrc修改吧。
不明白导出是?
另外就是若你没修改过启动,默认是有了的吧?所以你的问题应该是别的原因。
发表于 2023-7-9 07:56 | 显示全部楼层
如果是fcitx的问题,没理由只有你的电脑出问题而别的电脑正常的吧?所以应该是找错原因了吧
v20和v22在我处一直用着正常。
由于不知道你安装了什么或者修改了设置之类的原因引起,猜不出来。启动选项中有一项进空白系统的可以测试找出原因。
您需要登录后才可以回帖 登录 | 要注册

本版积分规则

QQ|手机版|Archiver|veket官方网站论坛 ( 粤ICP备 11052856 )

GMT+8, 2024-5-24 00:06

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表